Fixing 'Incompitable GLIBC' Libraries Installation

unset LD_LIBRARY_PATH

Ever installed any incompatible libraries to your RedHAT/CentOS system and got stuck ?! Don't worry we all did in some certain points, you can fix it by following the below method:

Reboot the machine into rescue mode

Unset the LD_LIBRARY_PATH so system not to use the third party libraries or the current ones.

unset LD_LIBRARY_PATH

Then install the right libraries for your system flavor and edition (below example is for glibc) :
(It's better to use --test for testing and check for errors before applying to system)

rpm -ivh file.rpm --test --force --noscripts --root=/mnt/sysimage

rpm -ivh glibc-<version>.rpm --force --nodeps --root=/mnt/sysimage

 


Subscribe to
for video tutorials updates